Problema con el Activity Editor

Ver el tema anterior Ver el tema siguiente Ir abajo

default Problema con el Activity Editor

Mensaje  FCS3584 el Vie 23 Jul 2010, 18:18

Después de correr varias actividades, algunas con éxito y otras no, me propuse aprender a armar yo una actividad. Para eso me hice del excelente tutorial del Ingeniero Jorge y empecé a trabajar. El primer traspié lo tuve cuando quise armar el consist del player con el editor, allí en cuanto quise colocar una locomotora diesel, se cerró todo y desapareció el MSTS, sin ningún aviso o mensaje de error. (Después hice pruebas con locomotoras a vapor, coches y vagones y no tiene ningún problema). Para sortear el problema, desempolvé el viejo Conbuilder y armé el consist que necesitaba.
Continué con el tutorial hasta grabar la actividad y poder probarla en el MSTS, hasta ahi todo de diez salvo el inconveniente anteriormente explicado. Vuelvo a agarrar el tutorial y Jorge explica como colocar material estático utilizable a lo largo de la ruta. Entro al editor, busco mi actividad y dentro de ella el lugar donde voy a colocar un consist (previamente armado tambien con el Conbuilder), aparece el punto, hago click con el botón derecho del mouse, seleccióno Place Consist y otra vez se cierra todo sin dar ningún error.
Busqué alguna explicación en el foro de Trensim pero no encontré ninguna respuesta a este error específico. A alguien le ocurrió esto o puede orientarme donde puede estar el problema.
Desde ya gracias.

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Leonardo Wonsik el Vie 23 Jul 2010, 18:27

Cómo estás, Guille?

Se me ocurre la idea de que bajes las exigencias gráficas del simulador. Esto lo tenés que hacer entrando al simulador en sí, no al editor, en ajustes, de pantalla, yo puse 800x600x16, teniendo un monitor que se bancaría un 1024x768x32 sin problemas... en Windows Millenium... yo tengo Xp.

Proba y contanos!

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Vie 23 Jul 2010, 19:02

Bien Leo, gracias. Y vos?

Probé lo que me digiste pero no hay caso se sigue colgando, en cuanto le das al Place Consist se vá. Mi PC está seteada a 1440x900 en 32 bits, pero el MSTS estaba en 1024x768x32 y por consejos que leí en Trensim lo bajé a 1024x768x16 para evitar problemas con el editor. Tambien lo corro en XP y el juego anda bien salvo en algunas actividades que en ciertas ocaciones se me tildó, quedando la pantalla congelada y funcionando el sonido, y tuve que resetear la PC porque ni el Ctrl+alt+Del funcionaba.

Lo que me llama la atención es que cuando quise armar un consist solamente se cuelga cuando quiero poner una locomotora diesel con una vaporera no hay problemas como tampoco con coches y vagones. No se si eso tendrá algo que ver.

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  damontej el Vie 23 Jul 2010, 19:05

No!!!
Si baja la resolución de pantalla a menos de 1024x768 no abre ningún editor del MSTS...

Lo que te diría de hacer es desde las opciones de pantalla del MSTS, bajes los requerimientos, empezando por sombras dinámicas y de todo tipo y con profundidad de color de 16bit en vez de 32.
Si a pesar de esto sigue la cosa, no veo otra que hacer los backups de material y rutas y desinstales MSTS y vuelvas a instalarlo...
Ojalá se arregle con lo primero.
Salutte!!!

_________________
Ing. Jorge Alberto Damonte
La cooperación es la convicción plena de que nadie puede llegar a la meta si no llegan todos.

damontej

Mensajes : 1699
Fecha de inscripción : 17/05/2010
Edad : 57
Localización : Ciudad Jardín, Lomas del Palomar

http://jorge.alberto.yebu.damonte

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Leonardo Wonsik el Vie 23 Jul 2010, 19:08

Te doy dos sugerencias, para seguir probando:

Está bien bajar de 32 a 16, pero probá, además, de 1024 a 800 (manteniendo los 16). Jorge, yo lo tengo a 800 y estoy creando una actividad sin problemas, y tengo tu mismo tipo de monitor, pero con la ventaja de tener Xp en vez de Seven. Aclaro: lo que bajo, no es la calidad de la pantalla en sí, sino la calidad visual del propio simulador.

Los estáticos ponelos en una actividad nueva, sin nada más que un player lo más básico posible. Una vez colocados todos los estáticos, con el Block de notas copiá las líneas del *.act nuevo al *.act donde está todo lo jugoso. Me abrevié un poco, si querés, explico mejor esto último.

Saludos!

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Vie 23 Jul 2010, 19:54

Leo y Jorge:

Hice lo me me aconsejaron, resolución del juego en 800x600x16 y los gráficos los baje todos, dándole mayor prioridad a la performance que a los gráficos y sigue igual.

Leo: donde estoy haciendo estas pruebas es en un tramo de la ruta del Roca entre Ezeiza y Cañuelas donde lo único que puse es el consist del player (g22+3materfer), sin ningún evento raro, que parte de Ezeiza y llega a Cañuelas y ahi se termina. Hasta ahí anduvo todo bien y con los gráficos a full.
El problema surge cuando quiero agregar los consist estáticos para que la actividad empiece a tomar un poco de color y siempre siguiendo el tutorial de Jorge.

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Leonardo Wonsik el Vie 23 Jul 2010, 20:04

¿El problema persiste?

Intentá de poner estáticos en una actividad nueva, sin tráfico ni nada más que un player, a ver si te deja agregar los estáticos.

Como dato adicional, te cuento que una vez me estudié todo el cuadro horario del tramo que mencionás, y te cuento, para cuando resuelvas este problema, que el ramal a Cañuelas tiene asignado tres formaciones Cool

Saludos!

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Vie 23 Jul 2010, 20:27

Leo:

Eso es lo que hago. Solamente tengo el Consist Player, no hay tráfico, al querer poner los estáticos, ahí se cuelga.

Si puedo resolver el problema, y cuando le tome la mano a las actividades, le podemos implementar los horarios que vos investigaste.

Saludos

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  damontej el Vie 23 Jul 2010, 23:56

Ahhhh
Entonces, creo que no zafás de reinstalar...
Uhh

_________________
Ing. Jorge Alberto Damonte
La cooperación es la convicción plena de que nadie puede llegar a la meta si no llegan todos.

damontej

Mensajes : 1699
Fecha de inscripción : 17/05/2010
Edad : 57
Localización : Ciudad Jardín, Lomas del Palomar

http://jorge.alberto.yebu.damonte

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Leonardo Wonsik el Sáb 24 Jul 2010, 00:02

En el Registro no modificaste nada, últimamente? Alguna otra modificación reciente?

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Sáb 24 Jul 2010, 00:30

Yo no modifiqué nada. Tendría que preguntarle a alguno de mis hijos si tocó algo, pero no creo que se metan con el MSTS porque no lo utilizan.

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Sáb 24 Jul 2010, 00:36

Jorge:

Según un comentario que hizo Leo, vos tenés el Windows 7 instalado. ¿Funciona bien el MSTS?

Porque cuando compré esta PC me instalaron el W7 pero como todavía no había drivers suficientes, lo saqué y le instalé el XP, no pudiendo utilizar los 4 GB de RAM que tengo instalados. Pero ahora, si es que tengo que reinstalar el MSTS aprovecho y vuelvo a instalarle el W7.

Saludos

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  damontej el Sáb 24 Jul 2010, 02:37

Funciona perfectamente.
Lo único a tener en cuenta es instalarlo en C:\Train Simulator para que no te inhiba de modificaciones a archivos de texto que están en C:\Archivos de programa
Además te digo que anda mejor en W7 que en XP, siempre y cuando tengás máquina de sobra para bancar holgado al S.O. (doble núcleo y 2GB RAM con disco S-Ata)
Salutte!!

_________________
Ing. Jorge Alberto Damonte
La cooperación es la convicción plena de que nadie puede llegar a la meta si no llegan todos.

damontej

Mensajes : 1699
Fecha de inscripción : 17/05/2010
Edad : 57
Localización : Ciudad Jardín, Lomas del Palomar

http://jorge.alberto.yebu.damonte

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Leonardo Wonsik el Sáb 24 Jul 2010, 08:32

Nunca usé W7, pero defiendo la idea de usar software anterior, basándome en lo que me dijo Neurus la última vez que nos vimos: él tiene Windows Millenium, o 98, uno de esos, no recuerdo bien cual, y nunca se le cierra ni el editor ni el simulador. Tengamos en cuanta que MSTS es del 2001, y Xp del 2003, ergo, software viejo con sistema operativo viejo.

Wenass

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Sáb 24 Jul 2010, 09:38

Gracias amigos.

Máquina tengo como para bancar al W7, de hecho cuando la compré me vino con él y andaba al pelo, lo que no sabía era lo de la instalación en c:\train simulator.

Leo lo que vos decís, estoy de acuerdo, pero para eso, hoy en día, tenés que tener una PC veterana y dedicada exclusivamente al MSTS y/o programas similares, sino te perdés un montón de programas modernos que ni de casualidad corren en W98. Es más no sé si en una máquina de las más elementales que podés comprar hoy, lo podés instalar.

Saludos

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Sáb 24 Jul 2010, 13:15

Jorge y Leo:

Antes de resignarme a tener que instalar todo nuevamente opté por hacer una última prueba y me dió muy buen resultado.

Cuando instalé el MSTS tuve la precaución de hacer copias de las carpetas originales antes de empezar a cargar add-ons, entre ellas ROUTES y TRAINS.
La prueba que hice fue la siguiente: Entré al MSTS y configuré todos los gráficos a full pero en 1024x768x16. Luego salí del simulador y fui a la carpeta del train simulator y allí reemplacé la actual carpeta TRAINS por la copia original. Entré al Editor Activity y fui a armar un nuevo consist, permitiéndome ingresar a las locomotoras diesel, salí del consist, fui a la ruta del Roca y en Ezeiza me permitió abrir el Place Consist e instalar uno de los consist originales. Primera conclusión: El problema no está en la instalación del MSTS sinó en la carpeta TRAINS.

La segunda prueba fue ver si el problema era en la carpèta CONSIST o en TRAINSET, para lo cual reinstalé la carpeta TRAINS en uso y dentro de ella reemplacé la carpeta CONSIST por la de CONSIST original. Entré al Activity Editor y me permitió crear consist y abrir el Place Consist. Segunda conclusión: El problema está en la carpeta CONSIST.

Estuve leyendo un poco en el foro de Trensim y algunos dicen que no podría haber más de 800 o 1000 consist en esa carpeta sino puede haber problemas, pero mi carpeta tiene 609 consist asi que esa no tendría que ser la falla.

Pregunta: ¿Hay alguna forma de determinar cual consist es el que causa el problema o me tengo que manejar a prueba y error?

Saludos

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  damontej el Sáb 24 Jul 2010, 13:51

Se me ocurre un trabajoso chequeo para averiguarlo.
Abrís el Editor de Actividades, y ruta por ruta, vas abriendo actividad por actividad, hasta que te salte que falta un consist o que hay alguna falla.
La manera sencilla que hace que la PC trabaje con eso por vos se llama Route Ritter.
Tiene una opción de análisis global de actividades, consist y material usado, que te da como resultado una lista, en la que lo que esté en rojo está faltando o está corrupto.
Elegí cuál usás...
Salutte

_________________
Ing. Jorge Alberto Damonte
La cooperación es la convicción plena de que nadie puede llegar a la meta si no llegan todos.

damontej

Mensajes : 1699
Fecha de inscripción : 17/05/2010
Edad : 57
Localización : Ciudad Jardín, Lomas del Palomar

http://jorge.alberto.yebu.damonte

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Sáb 24 Jul 2010, 14:37

Gracias Jorge.

A trabajar se ha dicho.

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  FCS3584 el Lun 26 Jul 2010, 11:39

Finalmente, después de estar todo el fin de semana con el Route-Riter y con el Conbuilder, logré reparar todos los consist de las actividades del Roca que tengo instaladas y pude colocar los consist estáticos en la actividad de práctica. Ahora me queda revisar los de las otras rutas que tambien tienen errores.

Núnca me hubiese imaginado que el editor era tan quisquilloso con los consist, está bien que algunos estaban armados con vehículos que tenían distinto tipo de enganche y había un par que tenían mezclados vehículos de trocha ancha con vehículos de trocha angosta ¿? (bajados con las actividades), pero el último no tenía ningún error aparente y lo solucioné abriéndolo con el Conbuilder y volviéndolo a grabar.

La conclusión final que saco de esto es que cuando se baja una actividad hay que revisar muy bien los consist, no solo por como vienen armados sino por el tipo de enganche que estamos usando para los vehículos utilizados en los consist incorporados.

Saludos

Guillermo

FCS3584

Mensajes : 170
Fecha de inscripción : 04/07/2010
Localización : Parque Chacabuco

Volver arriba Ir abajo

default Re: Problema con el Activity Editor

Mensaje  Contenido patrocinado Hoy a las 20:12


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.