Problema en la creacion de nueva ruta

Ver el tema anterior Ver el tema siguiente Ir abajo

default Problema en la creacion de nueva ruta

Mensaje  ebottazz el Miér 16 Mar 2011, 20:02

Que tal como les va. Soy usuario de tresim desde el año pasado. Hace un tiempo me he largado a usar el editor para crear mi propia ruta. Hace varios veces que le vewngo metiendo, tiempo y sudor... hasta ayer tambien un poco de lagrimas.... Ahhhh Recurro uds amigos argentinos fanas de los trenes para saber que le puede estar pasando al editor y si lo que perdi, se puede recuperar de algun modo. Hoy me puse pacientemente a recontruir lo que habia desaparecido, y me encontre con otro problema. Al tratar de seleccionar algunos tramos de vias y calles para borrarlas y pasar por arriba con tramos nuevos, me doy con que no puedo seleccionarlos y me da el mensaje que les muestro en la foto siguiente. No se como poder solucionarlo. Supongo que a toido aquel que se haya embarcado en esto quiza alguna vez le haya pasado. Que puedo hacer.... Shocked
Desde ya muchas gracias, y espero que cuando termine la ruta, poder compartirla con uds.
Saludos
Elvio
Cordoba, Argentina


ebottazz

Mensajes : 18
Fecha de inscripción : 16/11/2010
Edad : 52
Localización : Córdoba, Argentina

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ebottazz el Miér 16 Mar 2011, 20:21

ahora si que estoy en el horno.... cuando quiero cargar la ruta desde el editor, no se abre y el editor se cierra. Si trato de abrir con la opcion de "rebuild track data base", me da el error de la foto...
me quiero cortar la que te jedii meses y mese de trabajo, me quiero morir


ebottazz

Mensajes : 18
Fecha de inscripción : 16/11/2010
Edad : 52
Localización : Córdoba, Argentina

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  Leonardo Wonsik el Miér 16 Mar 2011, 20:30

Hola, bienvenido!

Hasta donde yo tengo entendido, y lo que vi de tus capturas, esa ruta ya está muerta. Crying or Very sad La solución, de aquí en adelante, es empezar de cero y, luego, cada vez que cerrás el editor, ejecutar un bat con el siguiente código:
Código:
@echo off
set u=
set /p u=
if defined u (
md B\%u%
)
call xcopy *.* B\%u%\ /y
call xcopy TILES\*.* B\%u%\Tiles\ /y
call xcopy WORLD\*.* B\%u%\world\ /y
del WORLD\*.bk
del WORLD\*.ws
del *bk
del B\%u%\*.haz
del B\%u%\*.ace
del B\%u%\*.bat
del B\%u%\*.ref
del B\%u%\*.mkr
del B\%u%\*.dat
call xcopy tsection.dat B\%u%\ /y
del TILES\*_e.raw
del TILES\*_n.raw
del B\%u%\TILES\*_e.raw
del B\%u%\TILES\*_n.raw
El cual, cuando lo arranques, te dará una ventanita negra con el cursor esperando que escribas y le des al ENTER. Lo que yo hago siempre es escribir la fecha y la hora. Muestro como ejemplo, la hora de este mensaje:
2011-03-16-20-31
Suerte!

Leonardo Wonsik

Mensajes : 1165
Fecha de inscripción : 19/05/2010
Edad : 29
Localización : Caraza y Remedios de Escalada

http://casa-anita.com.ar

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ganz_mavag el Miér 16 Mar 2011, 22:01

No esta muerta, el problema suele aparecer cuando se usan tramos de vias muy largos o un mismo tramo pasa por mas de 2 tiles, la solucion es simple:
- Detectar la posición donde se genera el error (el tile), tomar datos de latitud y longitud exactos en donde se posicionaron esos tramos
- Ir a la carpeta world y abrir el archivo .w correspondiente
- Buscar los objetos con la latitud/longitud que se regitro en el primer punto y borrarlos
-Guardar el .w (por las dudas, backupear el viejo)
- Abrir la ruta en el editor, regenerando el track database

Saludos!

_________________

ganz_mavag

Mensajes : 206
Fecha de inscripción : 18/05/2010
Edad : 46
Localización : FCGB Norte Km 17

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ebottazz el Miér 16 Mar 2011, 22:44

Leonardo Wonsik escribió:Hola, bienvenido!

Hasta donde yo tengo entendido, y lo que vi de tus capturas, esa ruta ya está muerta. Crying or Very sad La solución, de aquí en adelante, es empezar de cero y, luego, cada vez que cerrás el editor, ejecutar un bat con el siguiente código:
Código:
@echo off
set u=
set /p u=
if defined u (
md B\%u%
)
call xcopy *.* B\%u%\ /y
call xcopy TILES\*.* B\%u%\Tiles\ /y
call xcopy WORLD\*.* B\%u%\world\ /y
del WORLD\*.bk
del WORLD\*.ws
del *bk
del B\%u%\*.haz
del B\%u%\*.ace
del B\%u%\*.bat
del B\%u%\*.ref
del B\%u%\*.mkr
del B\%u%\*.dat
call xcopy tsection.dat B\%u%\ /y
del TILES\*_e.raw
del TILES\*_n.raw
del B\%u%\TILES\*_e.raw
del B\%u%\TILES\*_n.raw
El cual, cuando lo arranques, te dará una ventanita negra con el cursor esperando que escribas y le des al ENTER. Lo que yo hago siempre es escribir la fecha y la hora. Muestro como ejemplo, la hora de este mensaje:
2011-03-16-20-31
Suerte!

Muerta? nooooooooo!!!!!!
Sad Sad , no entiendo de ir todo bien en un par de dias que se vaya todo al joraca? Bueno si no queda otra habra que empezar de nuevo. Intentaré ver como puedo recuperar algo. El problema es que ahora el editor no me abre esa ruta y se cierra. Pregunta... y para que me serviría ese bat? o sea que funcion cumple?

ebottazz

Mensajes : 18
Fecha de inscripción : 16/11/2010
Edad : 52
Localización : Córdoba, Argentina

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ebottazz el Miér 16 Mar 2011, 22:50

ganz_mavag escribió:No esta muerta, el problema suele aparecer cuando se usan tramos de vias muy largos o un mismo tramo pasa por mas de 2 tiles, la solucion es simple:
- Detectar la posición donde se genera el error (el tile), tomar datos de latitud y longitud exactos en donde se posicionaron esos tramos
- Ir a la carpeta world y abrir el archivo .w correspondiente
- Buscar los objetos con la latitud/longitud que se regitro en el primer punto y borrarlos
-Guardar el .w (por las dudas, backupear el viejo)
- Abrir la ruta en el editor, regenerando el track database

Saludos!

Gracias por contestar... No es mi caso que algun tramo de vias pase por 2 o mas tiles. Este problema se me genero en la primera baldosa del terreno. Entiendo el proceder de tu mensaje, pero el problema mayor lo tengo, ahora, que el editor directamente no me abre la ruta. Alguna otra idea de como poder llegar a recuperar algo??? Crying or Very sad
Mira si esto te pasa cuando ya la estas por terminar???, es para arrancarse los pelos, jajaj HAHAHA


Última edición por ebottazz el Jue 17 Mar 2011, 10:35, editado 1 vez (Razón : corregir redacción)

ebottazz

Mensajes : 18
Fecha de inscripción : 16/11/2010
Edad : 52
Localización : Córdoba, Argentina

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  PaToPuNx el Jue 17 Mar 2011, 13:40

Solución: Backupear cada tanto...
Como puede ser que a mi me haya pasado una o dos veces nada mas eso en 10 años???
Cosa de locos...

Salu2 y suerte con eso che...

_________________
Tenemos un modelo, solo resta profundizarlo

PaToPuNx
Admin

Mensajes : 1349
Fecha de inscripción : 17/05/2010
Edad : 36
Localización : Aldo Bonzi y Base Merlo Km30P7

http://argensim.argentinaforo.net

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ebottazz el Jue 17 Mar 2011, 15:26

PaToPuNx escribió:Solución: Backupear cada tanto...
Como puede ser que a mi me haya pasado una o dos veces nada mas eso en 10 años???
Cosa de locos...

Salu2 y suerte con eso che...

Osea que a todos alguna vez nos pasa. Esta es la primera, espero que no sean mas. jejeje JUAAAZZ!!!

ebottazz

Mensajes : 18
Fecha de inscripción : 16/11/2010
Edad : 52
Localización : Córdoba, Argentina

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  ganz_mavag el Vie 18 Mar 2011, 15:11

El problema me dejó de ocurrir cuando empecé a salvar sin tener seleccionado ningún tramo de vía. Otra solución posible es recuperando el backup del *.w del tile, que tiene la extensión *.~w

_________________

ganz_mavag

Mensajes : 206
Fecha de inscripción : 18/05/2010
Edad : 46
Localización : FCGB Norte Km 17

Volver arriba Ir abajo

default Re: Problema en la creacion de nueva ruta

Mensaje  Contenido patrocinado Hoy a las 21:29


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.